Changes between Version 10 and Version 11 of Procedures/HyperspectralCalibrationCreation


Ignore:
Timestamp:
Apr 13, 2017 11:20:36 AM (7 months ago)
Author:
dac
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • Procedures/HyperspectralCalibrationCreation

    v10 v11  
    1 = Generating calibration files for Fenix =
     1= Generating calibration files for Hyperspectral data =
    22
    3 Radiometric, wavelength and miscellaneous other calibration of the Fenix is undertaken at ARSF-Ops at least annually since 2014. This page describes how to use the calibration software written by NERC-ARF-DAN to create the necessary calibration files from the raw calibration data. All progress should be recorded on a trac ticket (https://arsf-dan.nerc.ac.uk/trac/newticket) and added to the list below.
     3Radiometric, wavelength and miscellaneous other calibration of the Fenix hyperspectral instrument is undertaken in the calibration room at NERC-ARF Operations (now at BAS) and has been carried out  at least annually since 2014. This page describes how to use the calibration software written by NERC-ARF-DAN to create the necessary calibration files from the raw calibration data. All progress should be recorded on a trac ticket (https://nerc-arf-dan.pml/trac/newticket) and added to the list below.
    44
    5 2015: https://arsf-dan.nerc.ac.uk/trac/ticket/594 [[BR]]
    6 2016: https://arsf-dan.nerc.ac.uk/trac/ticket/613 [[BR]]
     52015: https://nerc-arf-dan.pml.ac.uk/trac/ticket/594 [[BR]]
     62016: https://nerc-arf-dan.pml.ac.uk/trac/ticket/613 [[BR]]
    77
    88== Setup ==
    99
    10 Relevant scripts are held in the arsf git repository under tools/libarsfcal.
     10Relevant scripts are held in the internal 'libarsfcal' git repository
    1111
    1212Note that the various calibration scripts written in Python expect to import a package called "libarsfcal". This means that you must have the directory above the libarsfcal directory in your PYTHONPATH environment variable for the scripts to run. This will be added by default but if you are making changes to the scripts you need to prepend the development version to your PYTHONPATH:
    1313
    14  1. export GITCHECKOUT=~/scratch_network/git/internal-code
    15  1. export PYTHONPATH=$GITCHECKOUT/tools:$PYTHONPATH
     14 1. export GITCHECKOUT=~/scratch_network/git/
     15 1. export PYTHONPATH=$GITCHECKOUT:$PYTHONPATH
    1616
    1717You can check the location of the library you are using with: