Version 49 (modified by mark1, 7 months ago) (diff)

--

Airborne Laser Scanner (ALS) processing

General Processing with a settings (.reg) file

  1. Start ALS PP (possibly using Linux)
  2. Load in the reg file to set the specific settings for the project.
  3. For Wine, Go to Inputs > Range Correction and for Intensity Based Range Correction browse to \users\rsg\arsf\calibration\lidar\... and select the relevant SN089_IBRC*txt (or *csv) file for the flight day you are processing
  4. Set the Goto Folder to the main project directory
    • File > Set Goto Folder
  5. Check the settings are appropriate for the project before proceeding (see below). This is important if using a reg file for a different project.
  6. Select POS filename
    • Click Browse and add the .sol file (posatt/ipas_honeywell/proc/)
  7. Select the Output directory
    • Click Select > Goto Folder and select <projname>/processing/als50/las. You should create directory if it doesn't exist.
  8. You will need to change the projection (File -> Output Options -> Change output format) Change: zone, horizontal datum, vertical datum (see below).
  9. You will need to output the AGC value in the point id field. (in output options)
  10. You will also need to set ALSPP to generate a unique GUID for each LAS file. (Select Generate new GUID under options LAS File GUID)
  11. Save settings for future re-processing purposes.
    • File > Save Settings (e.g. processing/als50/2009280b.reg)
    • Alternatively if this fails (Fedora 24 onwards) then use the command :save_alspp_settings.sh <filename>
  12. Add the raw SCN data
    • Click Add and browse to the parent raw data directory. This will add all flight lines in the immediate child directories. lidar->als50->RawLaser
  13. Run the processing
    • Run > Run

Before running your processing

You should check the following items in your settings:

  1. maximum and minimum angle to process
    • These should be 45 and -45
  2. minimum and maximum range to process
    • These should be 150.000m and 15000.000 m

Otherwise most settings should have been set in the boresight and won't need to be changed, if you are particularly concerned check the boresight ticket for the values noted there. If any of these values are incorrect you must inform everyone else and repair the boresight settings file.

Generation of TRJ files

If you are creating full waveform data (you probably are!) you should make sure each las file has a trj file generated with the lines specific pitch and roll adjustment.

Setup of the system

  • Hardware options. Once set these should never change (unless the system is modified etc) Should be supplied when the system is delivered. Can view/set these from File > Processing Options.
  • Output file options. Set the projection details (usually OSGB36, for UK), LAS file format, and whether want GeoTIFF or ASCII output awswell. Also contains options for debugging.

UK Flights

  • System: UK and Ireland
  • Zone: OSGB (OSTNO2)
  • Horizontal datum: ETRF89 (Units: Meters)
  • Vertical datum: Newlyn (Units: Meters)

International Flights

  • System: UTM
  • Zone: (Refer to a UTM Zone Map, note: North or South)
  • Horizontal datum: WGS84 (Units: Meters)
  • Vertical datum: WGS84 (Units: Meters)
  • Input options
    • Atmospheric Correction. Need values of the altitude, temperature and pressure for a low altitude and high altitude. With these values a correction gradient will be produced.
    • Range Correction. A time-distance delay in metres of the ALS system, in the measurement of range data. (This is complicated...see user manual for details)
    • Scanner Correction. These do not need to be changed after the calibration/boresighting of the system.
    • POS errors. Angular difference between the IMU and the ALS optics reference frames. Needs to be known accurately.
    • Elevation offset. This needs to be set if we have ground control points: is normally non-zero. It is identified using the TScan Control Report (eh?). The LIDAR is then reprocessed using the opposite of the DZ offset.
    • Intensity. Use the Raw intensity.

Possible errors

  • ALSPP.EXE on Linux

  1. If a Windows crash message appears when trying to 'Run', ensure the POS file is pointed to on the Linux filesystem and not the Windows hard drives (D:,.. etc.).
  2. If an error message claims an "invalid IBRC file" was specified when trying to Run, this can happen because the intensity based range correction file was not correctly specified under Input > Range Correction. Make sure the correct .txt file is being used, or try any others in the same directory.

ALSPP Known Bugs

Two known issues with LAS files produced using ALSPP (using Ver 2.74#8):

  • The EPSG codes are not populated correctly (using WGS84 UTM). Under the key 3076, ProjLinearUnitsGeoKey, it should give the linear units instead it gives the projection code. The key 3072 ProjectedCSTypeGeoKey is missing, which should contain the projection code. Thus a program that tries to out projection information and follows geoTIFF specification will fail because ProjLinearUnitsGeoKey holds incorrect information and ProjectedCSTypeGeoKey doesn't exist.
  • The max/min values in the header file are incorrect so there are usually a couple of points in the file that are outside the bounding box. Some programs then exclude these points as they only read those point within the max/min values given in the header.

These have been reported to Leica Support 08/07/2012, who have forwarded to their development team.